re = /(?<!\S)(inn)|([^aeiou\r\n])\2+/
str = 'asso
assso
assocco
innasso
inninnasso'
subst = '$1$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result