#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[^,]*(,\s*другой,)"
Local $sString = "различный, разный, другой, отличный от, необычный, неодинаковый, непохожий, не такой" & @CRLF & _
"втор ой, другой, второй, секунда, вторым номером, подкреплять" & @CRLF & _
"тут может быть любое количество слов главное чтобы до запятой, другой, второй, секунда, подкреплять" & @CRLF & _
"другой, остальные, иной, другой, иначе"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")