$re = '/^[^,]*(,\s*другой,)/m';
$str = 'различный, разный, другой, отличный от, необычный, неодинаковый, непохожий, не такой
втор ой, другой, второй, секунда, вторым номером, подкреплять
тут может быть любое количество слов главное чтобы до запятой, другой, второй, секунда, подкреплять
другой, остальные, иной, другой, иначе';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);