package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:[^!]\[(?P<caption>.*?)\])\((?P<image>.*?)\)`)
var str = `This is a regex to detect markdown image links of the form 
{#fig:id}
{#fig:id tag="B.1"}
{#fig:ch0_1_images-1 width=100%}





















`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}