Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
r"
(?:[^!]\[(?P<caption>.*?)\])\((?P<image>.*?)\)
"
gm
Input 1
1
New
This is a regex to detect markdown image links of the form  {#fig:id} {#fig:id tag="B.1"} {#fig:ch0_1_images-1 width=100%}