const regex = new RegExp('(?:[^!]\\[(?P<caption>.*?)\\])\\((?P<image>.*?)\\)', 'gm')
const str = `This is a regex to detect markdown image links of the form 
{#fig:id}
{#fig:id tag="B.1"}
{#fig:ch0_1_images-1 width=100%}





















`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}