use strict;
my $str = 'This is a regex to detect markdown image links of the form 
{#fig:id}
{#fig:id tag="B.1"}
{#fig:ch0_1_images-1 width=100%}





















';
my $regex = qr/(?:[^!]\[(?P<caption>.*?)\])\((?P<image>.*?)\)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}