re = /(?:[^!]\[(?P<caption>.*?)\])\((?P<image>.*?)\)/m
str = 'This is a regex to detect markdown image links of the form 
{#fig:id}
{#fig:id tag="B.1"}
{#fig:ch0_1_images-1 width=100%}





















'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end