// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[\s\S]*\b(\d+)").unwrap();
let string = "My ID is 112243 and my phone number is 0987654321. Thanks you.
My ID is 112243 and my phone number is 0987654321. Thanks you.
My ID is 112243 and my phone number is 0987654321. Thanks you.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}