package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?ms)(?&valid_text)(?(DEFINE)
(?<valid_text>
\A\s*(?&version)\s*
(?: (?&element) \s* )+
\s*\Z
)
(?<version>
version\(.+?\);
)
(?<element>
element\s*
(?&element_body);
)
(?<element_body>
\( (?: [^()]++ | (?&element_body) )* \)
)
)`)
var str = `version();
element
(
);
garbage <--- THIS SHOULD NOT MATCH!
element
(
);
element
(
);`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}