re = /(?&valid_text)(?(DEFINE)
(?<valid_text>
\A\s*(?&version)\s*
(?: (?&element) \s* )+
\s*\Z
)
(?<version>
version\(.+?\);
)
(?<element>
element\s*
(?&element_body);
)
(?<element_body>
\( (?: [^()]++ | (?&element_body) )* \)
)
)/xm
str = 'version();
element
(
);
garbage <--- THIS SHOULD NOT MATCH!
element
(
);
element
(
);'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end