$re = '/^「(?<busname>[\p{Han}]\d{1,2})\s(?<destination>[\p{Han}]+)行き・(?<boardedat>[\p{Han}]+)」/mu';
$str = '「渋11 渋谷駅行き・駒沢大学駅前」でタッチしました。';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);