# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\(([^(){},]+|\((?:[^(),]+,[^(),]+)\)|({(?:[^{}]+|(?-1))++}))(?:,(?2))+),"
test_str = ("Should work for:\n"
"(1,2,3)\n"
"(1,2,3,4)\n"
"((1,2),3,4)\n"
"(((1,2,3),4),5)\n"
"({x},{y},{z})\n"
"(1,(2,3),4)\n"
"((1,2),(3,4),5)\n"
"((1,2),3,(4,5))\n"
"(1,(2,(3,4),5))\n"
"(1,(2,({3},4),5))\n"
"(1,{{1},{1,2}},3)\n\n"
"Should not work for:\n"
"(1,2)\n"
"(10,10)\n"
"(1,10)\n"
"((1,2),3)\n"
"(((1,1),1),1)\n"
"({0},1)\n"
"({{x},{x,y}},z)")
subst = "($1),"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.