Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Regular
Expressions
101
Regular
Expressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
^[a-z0-9.]*:(?!jar)
/
gm
Test String
New
com.test.api:super.duper-api:jar:1.2.3:compile super.duper.api:jar:1.2.3:compile