import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!(%\\\\(?:no)?cite\\w*\\{([^\\}]*?)\\}))[^*\\n]*$";
final String string = "blablabla\n"
+ "Author et. al \\cite{author92} bla bla. % should match\n"
+ "\\citep{author93} % should match\n"
+ "\\nocite{author94} % should match\n"
+ "100\\%\\nocite{author95} % should match\n"
+ "100\\% \\nocite{author95} % should match\n"
+ "%\\nocite{author96} % should not match\n"
+ "\\cite{author97, author98, author99} % should match\n"
+ "\\nocite{*} % should not match";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}