use strict;
my $str = 'blablabla
Author et. al \\cite{author92} bla bla. % should match
\\citep{author93} % should match
\\nocite{author94} % should match
100\\%\\nocite{author95} % should match
100\\% \\nocite{author95} % should match
%\\nocite{author96} % should not match
\\cite{author97, author98, author99} % should match
\\nocite{*} % should not match';
my $regex = qr/^(?!(%\\(?:no)?cite\w*\{([^}]*?)\}))[^*\n]*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}