import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "food/(.+?)/([^/]+)-recipes/?$";
final String string = "food/onion/onion-recipes\n"
+ "food/onion/onion-recipes/\n"
+ "food/onion/child/child-recipes\n"
+ "food/onion/child/child-recipes/\n"
+ "food/onion/onion-blablah";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}