re = /food\/(.+?)\/([^\/]+)-recipes\/?$/m
str = 'food/onion/onion-recipes
food/onion/onion-recipes/
food/onion/child/child-recipes
food/onion/child/child-recipes/
food/onion/onion-blablah'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end