re = /((([01]?[0-9]|2[0-3]):[0-5][0-9])|sunrise)-((([01]?[0-9]|2[0-3]):[0-5][0-9])|sunset)(,((([01]?[0-9]|2[0-3]):[0-5][0-9])|sunrise)-((([01]?[0-9]|2[0-3]):[0-5][0-9])|sunset))*/m
str = '00:00-13:59,15:00-23:10,15:00-23:10'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result