// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)((([01]?[0-9]|2[0-3]):[0-5][0-9])|sunrise)-((([01]?[0-9]|2[0-3]):[0-5][0-9])|sunset)(,((([01]?[0-9]|2[0-3]):[0-5][0-9])|sunrise)-((([01]?[0-9]|2[0-3]):[0-5][0-9])|sunset))*").unwrap();
let string = "00:00-13:59,15:00-23:10,15:00-23:10";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}