#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "^news\/[0-9]+-(.*)"
Local $sString = "news/122-windows-10-the-final-countdown"
Local $sSubst = "headlines\/$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)