use strict;
my $str = 'news/122-windows-10-the-final-countdown';
my $regex = qr/^news\/[0-9]+-(.*)/p;
my $subst = 'headlines\\/$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";