import Foundation
let pattern = #"^news\/[0-9]+-(.*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"news/122-windows-10-the-final-countdown"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"headlines\/$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)