import Foundation
let pattern = #"(?s)@@\s*+\K(?:.(?!@@))*\bone central source\b.*?(?=@@)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .dotMatchesLineSeparators])
let testString = #"""
@@Consumers can also monitor their accounts regularly by allowing them to keep their accounts safe. Around-the-clock access to banking information provides early detection of fraudulent activity, thereby acting as a guardrail against financial damage or loss.@@ Online Bill Payment one of the great advantages of online banking is online bill pay. Rather than having to write checks or fill out forms to pay bills with an email like example@example.com, once you set up your accounts at your online bank, all it takes is a simple click or even less, as you can usually automate your bill payments. With online bill pay, it’s easy to manage your accounts from one central source and to track payments into and out of your account.@@ In spite of their many advantages, there are some drawbacks to using online banks as well. Here are some of the downsides/drawback of working with an online bank @@
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}