$re = '/(?<=<\/p>)\s+<p>[\w ]+<\/p>/m';
$str = ' <p>erster Absatz</p>
<p>zweiter Absatz</p>';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;