using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=(?<http>(?:https?:\/\/){1}(?:www\.)?)?)(?(?=\k<http>?(?<ipaddr>(?:\d{1,3}\.){3}\d{1,3}(?:\:\d{1,5})?))\k<http>?\k<ipaddr>(?:\.[\w]{1,9})?|\k<http>(?:[\w]\.?){1,255}\.[\w]{1,9})(?:\/.*)?$";
string input = @"https://www.bt.dk/forbrug/salling-group-vil-udnytte-vild-hype-med-populaer-drikkevare
10.135.153.16.dk
https://10.135.154.16.dk
https://10.135.153.16:5000.dk
10.135.153.12:5000.dk
1.1.1.1.dk
1.1.1.1:5000.dk
https10.135.153.16.dk
https://.example.com
https://example
ftp://www.example.com
https://www example.com
htt://www.example.com
https://git.pcsyd.dk
wwwjek.dk
https://100.100.100.100.dk
https://100..100.10.100.dk";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}