use strict;
my $str = 'A
ACDT
ACST
ACT
ACT
ACWST
ADT
ADT
AEDT
AEST
AET
AFT
AKDT
AKST
ALMT
AMST
AMST
AMT
AMT
ANAST
ANAT
AQTT
ART
AST
AST
AT
AWDT
AWST
AZOST
AZOT
AZST
AZT
AoE
B
BNT
BOT
BRST
BRT
BST
BST
BST
BTT
C
CAST
CAT
CCT
CDT
CDT
CEST
CET
CHADT
CHAST
CHOST
CHOT
CHUT
CIDST
CIST
CKT
CLST
CLT
COT
CST
CST
CST
CT
CVT
CXT
ChST
D
DAVT
DDUT
E
EASST
EAST
EAT
ECT
EDT
EEST
EET
EGST
EGT
EST
ET
F
FET
FJST
FJT
FKST
FKT
FNT
G
GALT
GAMT
GET
GFT
GILT
GMT
GST
GST
GYT
H
HDT
HKT
HOVST
HOVT
HST
I
ICT
IDT
IOT
IRDT
IRKST
IRKT
IRST
IST
IST
IST
JST
K
KGT
KOST
KRAST
KRAT
KST
KUYT
L
LHDT
LHST
LINT
M
MAGST
MAGT
MART
MAWT
MDT
MHT
MMT
MSD
MSK
MST
MT
MUT
MVT
MYT
N
NCT
NDT
NFDT
NFT
NOVST
NOVT
NPT
NRT
NST
NUT
NZDT
NZST
O
OMSST
OMST
ORAT
P
PDT
PET
PETST
PETT
PGT
PHOT
PHT
PKT
PMDT
PMST
PONT
PST
PST
PT
PWT
PYST
PYT
PYT
Q
QYZT
R
RET
ROTT
S
SAKT
SAMT
SAST
SBT
SCT
SGT
SRET
SRT
SST
SYOT
T
TAHT
TFT
TJT
TKT
TLT
TMT
TOST
TOT
TRT
TVT
U
ULAST
ULAT
UTC
UYST
UYT
UZT
V
VET
VLAST
VLAT
VOST
VUT
W
WAKT
WARST
WAST
WAT
WEST
WET
WFT
WGST
WGT
WIB
WIT
WITA
WST
WST
WT
X
Y
YAKST
YAKT
YAPT
YEKST
YEKT
Z';
my $regex = qr/^(?:A(?:C(?:WS|[DS])?T|DT|E[DS]?T|FT|K[DS]T|LMT|M[S]?T|NAS?T|QTT|RT|ST|W[DS]T|Z(?:OS|[OS])?T|oE|T)|B(?:RS|[NORST])T|C(?:AS|ES|H(?:A[DS]|OS|[OU])|ID?S|LS|hS|[ACDEKLOSVX])?T|D(?:AV|DU)T|E(?:ASS?|ES|GS|[ACDEGS])?T|F(?:JS|KS|[EJKN])T|G(?:A[LM]|IL|[EFMSY])T|H(?:OVS?|[DKS])T|I(?:R(?:KS|[DKS])|[CDOS])T|JST|K(?:OS|RAS?|UY|[GS])T|L(?:H[DS]|IN)T|M(?:A(?:GS|[GRW])T|DT|HT|MT|S[DKT]|UT|VT|YT|T)|N(?:FD|OVS?|Z[DS]|[CDFPRSU])T|O(?:MSS?|RA)T|P(?:ETS?|HO|M[DS]|ON|YS|[DEGHKSWY])?T|QYZT|R(?:OT|E)T|S(?:A[KMS]|RE|YO|[BCGRS])T|T(?:AH|OS|[FJKLMORV])T|U(?:LAS?T|TC|YS?T|ZT)|V(?:LAS?|OS|[EU])T|W(?:A(?:RS|[KS])?T|ES?T|FT|GS?T|I(?:TA|[BT])|ST|T)|Y(?:A(?:KS|[KP])|EKS?)T|[ABCDEFGHIKLMNOPQRSTUVWXYZ])$/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";