package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)("[^\s"]+":\s*")\d+(?:\.\w+(?:-\w+)*)+",`)
var str = `"@material-ui/core": "4.11.4",
"@material-ui/icons": "4.11.2",
"@material-ui/lab": "4.0.0-alpha.58",
"@material-ui/styles": "4.11.4",`
var substitution = "$10.0.0","
fmt.Println(re.ReplaceAllString(str, substitution))
}