const regex = /("[^\s"]+":\s*")\d+(?:\.\w+(?:-\w+)*)+",/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('("[^\\s"]+":\\s*")\\d+(?:\\.\\w+(?:-\\w+)*)+",', 'gm')
const str = `"@material-ui/core": "4.11.4",
"@material-ui/icons": "4.11.2",
"@material-ui/lab": "4.0.0-alpha.58",
"@material-ui/styles": "4.11.4",`;
const subst = `$10.0.0",`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);