import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([^\"\\s]+)+: ?\\{";
final String string = "{\n"
+ " area: {\n"
+ " \"lang\": \"en\",\n"
+ " \"area\": \"25\",\n"
+ " \"region\": \"mea\"\n"
+ " },\n"
+ " config: {\n"
+ " \"rtl\": false,\n"
+ " \"breakpoint\": 768\n"
+ " }\n"
+ "}";
final String subst = "\"$1\": {";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}