#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)bureaux? (à l'[eé]tage|[ée]quip[ée]s?|cloisonn[ée]s)"
Local $sString = "REGEX_1 =(avec|(partie|à usage|compos[ée]) de|(possibilit[eé]|zone|espace)(\sde)?) bureaux?" & @CRLF & _
"" & @CRLF & _
"REGEX_2 =\d*((\s)?[m²|m|M]) de bureaux?|bureaux? d'une surface de (\d*)((\s)?[m²|m|M])|bureaux? de (\d*)((\s)?[m²|m|M])" & @CRLF & _
"" & @CRLF & _
"REGEX_3 =bureaux? (à l'[eé]tage|[ée]quip[ée]s?|cloisonn[ée]s)" & @CRLF & _
"" & @CRLF & _
"REGEX_2NOT = " & @CRLF & _
"(proche de bureaux?| " & @CRLF & _
"bureaux? proche|" & @CRLF & _
"bureaux? [àa] proximit[eé]| " & @CRLF & _
"[àa] proximit[eé] de bureaux?)" & @CRLF & _
"" & @CRLF & _
"[EXEMPLE]" & @CRLF & _
"avec bureau" & @CRLF & _
"à usage de bureaux" & @CRLF & _
"composé de bureau" & @CRLF & _
"d'activites & bureaux" & @CRLF & _
"activités/bureaux " & @CRLF & _
"une partie de bureau" & @CRLF & _
"et bureau" & @CRLF & _
"et de bureau " & @CRLF & _
"12m² de bureaux" & @CRLF & _
"de bureaux de 12m²" & @CRLF & _
"bureaux d'une surface de 12m²" & @CRLF & _
"bureaux à l'étage" & @CRLF & _
"bureaux équipés" & @CRLF & _
"zone bureau" & @CRLF & _
"bureaux cloisonnés" & @CRLF & _
"possibilité de bureau" & @CRLF & _
"espace bureau" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"[NE PAS TENIR COMPTE]" & @CRLF & _
"bureaux proche" & @CRLF & _
"bureaux à proximité " & @CRLF & _
"à proximité de bureau"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")