#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "plafonders$"
Local $sString = "+---------+-----------------+" & @CRLF & _
"| id_word | word |" & @CRLF & _
"+---------+-----------------+" & @CRLF & _
"| 177041 | utvälj |" & @CRLF & _
"| 119270 | fonders |" & @CRLF & _
"| 39968 | flamländarens |" & @CRLF & _
"| 63567 | hänvisningarnas |" & @CRLF & _
"| 61244 | hovdansers |" & @CRLF & _
"+---------+-----------------+"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")