// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"((http(s)?:\/\/)?(www\.)?youtube\.com\/@.*)|((http(s)?:\/\/)?(www\.)?twitch\.tv\/.*)").unwrap();
let string = "https://www.youtube.com/@mallusrgreat
http://www.youtube.com/@mallusrgreat
http://youtube.com/@mallusrgreat
https://youtube.com/@mallusrgreat
https://www.youtube.com/@mallusrgreat/
http://www.youtube.com/@mallusrgreat/
http://youtube.com/@mallusrgreat/
https://youtube.com/@mallusrgreat/
asdsadhttp://youtube.com/@mall
https://www.twitch.tv/aus24
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}