package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\h+|\h+$|(\R){2,}|(\s){2,}`)
var str = ` 1 . BritishAirways 15FEB LONDON HONGKONG
2 . CathayPacific 01MAR HONGKONG SHANGHAI
3 . Qantas 12MAR SINGAPORE SYDNEY`
var substitution = "$1$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}