#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[^,\n]+"
Local $sString = "4/5/2015 13:34,Apples,73" & @CRLF & _
"4/5/2015 3:41,Cherries,85" & @CRLF & _
"4/6/2015 12:46,Pears,14" & @CRLF & _
"4/8/2015 8:59,Oranges,52" & @CRLF & _
"4/10/2015 2:07,Apples,152" & @CRLF & _
"4/10/2015 18:10,Bananas,23" & @CRLF & _
"4/10/2015 2:40,Strawberries,98"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")