const regex = /(?<="token":")[^"]+(?=")/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<="token":")[^"]+(?=")', 'gm')
const str = `{"name": "Zahid","token":"123456"}`;
const subst = `78919`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);