use strict;
my $str = '{"name": "Zahid","token":"123456"}';
my $regex = qr/(?<="token":")[^"]+(?=")/mp;
my $subst = '78919';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";