import Foundation
let pattern = #"(?<="token":")[^"]+(?=")"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"{"name": "Zahid","token":"123456"}"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"78919"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)