using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\[\[[(table|pre|text) ]*[\n ].*)({.*})";
string input = @"[[table
{json here: ""asdas""}
]]
[[pre
{json here: ""asdasx""}
]]
[[text {json here: ""red""} ]]";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}