const regex = new RegExp('((?=\\S*?[A-Z])(?=\\S*?[^\\w\\s])(?=\\S*?[a-z])(?=\\S*?[0-9]).{8,})\\S', 'gm')
const str = `This@154p455word
notapaSsw0rd`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}