$re = '/((?=\S*?[A-Z])(?=\S*?[^\w\s])(?=\S*?[a-z])(?=\S*?[0-9]).{8,})\S/m';
$str = 'This@154p455word
notapaSsw0rd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);