# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(^[ \t]*)Function([^\n\;\\/]*);?/$1 public static$2\n$1\{/gm;t' <<< "// Возвращает значения Х и У
Function UseResolutionMultipler(x# Var,y# Var) ;
//SetScale ScX,ScY
End Function ;
Function DrawBar(x,y,Width ,Height,CurPts,MaxPts);
jjj
End Function;"