use strict;
my $str = '// Возвращает значения Х и У
Function UseResolutionMultipler(x# Var,y# Var) ;
//SetScale ScX,ScY
End Function ;
Function DrawBar(x,y,Width ,Height,CurPts,MaxPts);
jjj
End Function;';
my $regex = qr/(^[ \t]*)Function([^\n\;\/]*);?/mp;
my $subst = '$1 public static$2\\n$1\\{';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";