import Foundation
let pattern = #"(\w+:\/\/[\w\.]+?\/([\w\.]+?)\/([\w\.]+?))\s"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
1. https://github.com/ymcatwincities/openy_block_modal - Implements a simple block with a body and title that will be used to display modal windows.
1. https://github.com/ymcatwincities/openy_memberships - Membership Framework for OpenY and Drupal.
1. https://github.com/ymcatwincities/openy_prgf_sidebar_menu - SideBar menu for referencing menu blocks and using in SideBars across different pages.
1. https://packagist.org/packages/openy/openy_loc_finder - Extended Location Finder
1. https://github.com/Open-Y-subprojects/reqclique_gxp_sync - Reqclique Group Exercise Sync
1. https://github.com/open-y-subprojects/virtual_y_signaling_server - Signalling server for Virtual Y
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"[$2/$3]($1) "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)