using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"https:\/\/([a-z\.]{4})?([0-9]+.hs-sites|wthubspot|hubspot).com[\/]?";
string input = @"https://hubspot.com
https://www.hubspot.com/
https://wthubspot.com/
https://123456.hs-sites.com/
https://google.com";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}