const regex = new RegExp('(?:<select\\b|\\G).*?(\\b\\d{4}(?:\\s*\\d{4}){3}\\b)(?=.*?</select>)', 'g')
const str = `blah 1234 1234 4567 5678 blah
<select id="test:j_id_ca" name="test:j_id_ca" class="x2h" style="font-weight:bold;"><option value="0" selected>1111 1111 1111 1111</option><option value="0" selected>2222 2222 2222 2222</option></select>
blah 1234 1234 4567 5678 blah
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}