re = /^(?:\b(?:, ?)?(Apple|Bat|Car)\b(?!.*?\b\1\b)){3}$/mi
str = 'Bat, Car, Apple
Car, Bat, Apple
Apple, Car, Bat
Apple, Car, Bat, Stick
Bat, Car
Apple
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end