$re = '/<!--BEGIN DELIMITER\((?<expr>(\w+))\)-->(?<content>([\s\S]*?))<!--END DELIMITER\((\k<expr>.*)\)-->/';
$str = ' <!--BEGIN DELIMITER(A)-->
sample text
<!--BEGIN DELIMITER(B)-->
another sample text
<!--END DELIMITER(B)-->
<!--END DELIMITER(A)-->';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);