#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<iframe[\S\s]*?src=".*?\.(\w+)\..*?""
Local $sString = "<iframe id="ytplayer" type="text/html" width="640" height="360"" & @CRLF & _
" src="http://www.youtube.com/embed/M7lc1UVf-VE?autoplay=1&origin=http://example.com"" & @CRLF & _
" frameborder="0"/>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")