import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<iframe[\\S\\s]*?src=\".*?\\.(\\w+)\\..*?\"";
final String string = "<iframe id=\"ytplayer\" type=\"text/html\" width=\"640\" height=\"360\"\n"
+ " src=\"http://www.youtube.com/embed/M7lc1UVf-VE?autoplay=1&origin=http://example.com\"\n"
+ " frameborder=\"0\"/>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}